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INTERNAL EXAMINER EXTERNAL EXAMINER 



GENERAL INSTRUCTIONS 
 
 All the students are instructed to wear protective uniform and shoes before 

entering into the laboratory. 

 Before starting the exercise, students should have a clear idea about the 

principles of that exercise 

 All the students are advised to come with completed recorded and corrected 

observation book of previous experiments, defaulters will not allowed to do their 

experiment. 

 Don’t operate any instrument without getting concerned staff member’s prior 

permission. 

 All the instruments are costly. Hence handle them carefully, to avoid fine for 

any breakage. 

 Almost care must be taken to avert any possible injury while on laboratory work. 

In case, anything occurs immediately report to the staff members. 

 One student from each batch should put his/her signature during receiving the 

instrument in instrument issue register. 
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AI8711 GIS Laboratory for Agriculture Engineers 

List of Experiments 

 

1. Measurement of Relief Displacement using Parallax Bar 

2. Stereoscopic Vision Test 

3. Aerial Photo Interpretation - Visual 

4. Satellite Images Interpretation – Visual 

5. Introduction to QGIS 

6. Geo-referencing of Images 

7. Image Enhancement practice 

8. Supervised Classification Practice 

9. Unsupervised Classification Practice 

10. Database Management Systems 

11. Spatial Data Input and Editing - Digitizing 

12. Raster Analysis Problems – Database Query 

13. GIS Applications in DEM and its Analysis 

14. GIS Application in watershed Analysis 

15. GIS Application in Rainfall-Runoff Modelling 

16. GIS Application in Soil Erosion Modelling 

 

 

 

 

 



Ex.No:01  

Date: 

Measurement of Relief Displacement using Parallax Bar 

 

Parallax Height Measurement  

Parallax is the apparent displacement in the position of an object, with respect to 

a frame of reference, caused by a shift in the position of observation. The differences in 

the parallax of various objects of interest (called differential parallax) can be used to 

measure the heights of objects and to extract topographic information. 

 

Fundamentals of Human Stereoscopy  

Stereoscopy is the science of perceiving depth using 

two eyes. When a human being's two eyes (binocular 

vision) are focused on a certain point, the optical 

axes of the eyes converge on that point, forming 

parallactic angle (φ). The near the object, the greater 

the parallactic angle. The brain has learned to 

associate distance with corresponding parallactic 

angles and give the viewer the visual and mental 

impression which object is closer. This is the basis of depth perception. 



If both objects were exactly the same distance from the viewer, then the parallactic 

angles will be the same and the viewer would perceive them at as being the same 

distance away. The maximum distance at which distinct stereoscopic depth perception 

is possible is approximately 1000 meters for the average adult. 

 

 

 

Viewing Stereoscopic Aerial Photographs  

 Principal Point and Conjugate Principal Point are located on each photograph. 

Drawn a line through them on each photograph can identify the flight line.  

 Slides one of the photographs left or right so that a portion of the stereoscopic 

overlap area is visible.  

 The stereoscope is placed above the overlap area and stereoscopic viewing takes 

place. The common overlap area of a pair of 9x9 in aerial photographs taken 60 

percent overlap is about 5.4 in. that can be viewed in stereo. 

 



 

 

 



Ex.No:02 

Date: 

Stereoscopic Vision Test 

Description 

 



 

 

 



 

 

 



 

 



 

 

 

 

 

 

 

 

 

 

 



Ex.No:03 

Date 

Aerial photo interpretation – visual 

 

Aim 

To identify earth objects and judge their significance for given aerial 

photograph.  

 

Description 

 Image interpretation is the process of extraction of information both 

qualitative and quantitative from aerial photographs and satellite images in the 

form of a map. This technique is used to collect information for a variety of 

purposes. 

 Image interpretation is carried out either manually or with the help of 

computer software and is known as visual and digital interpretation, 

respectively.  

 Visual interpretation is a process of identifying features seen on 

photographs/images and communication of information obtained from them 

to others for evaluating their significance.  

 The information extraction from aerial data (i.e. photo interpretation) is based 

on the characteristics of photograph features, such as size, shape, tone, texture, 

shadow, pattern, and association.  

 The criteria for identification of an object with interpretation elements are 

called an interpretation keys. 

 

 



Procedure 

 Open QGIS. 

 Click on Add data tool and add the given aerial photograph. 

 Identify the earth objects with the help of elements of image interpretation. 

 Show the identified feature with label. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Result 

The earth objects were identified with reference of image elements for given 

aerial photograph. 



Ex.No:04 

Date: 

Satellite Image Interpretation – Visual 

Aim 

To identify earth objects and judge their significance for given satellite image.  
 

Description 

 Image interpretation is the process of extraction of information both 

qualitative and quantitative from aerial photographs and satellite images in the 

form of a map. This technique is used to collect information for a variety of 

purposes. 

 Image interpretation is carried out either manually or with the help of 

computer software and is known as visual and digital interpretation, 

respectively.  

 Visual interpretation is a process of identifying features seen on 

photographs/images and communication of information obtained from them 

to others for evaluating their significance.  

 The information extraction from satellite images (i.e. image interpretation) is 

based on the characteristics of photograph features, such as size, shape, tone, 

texture, shadow, pattern, and association. The basic elements of visual image 

interpretation are similar to those used in aerial photo interpretation.  

 The criteria for identification of an object with interpretation elements are 

called an interpretation keys. 

 

 

 



Procedure 

 Open QGIS. 

 Click on Add data tool and add the given satellite image. 

 Identify the earth objects with the help of elements of image interpretation. 

 Show the identified feature with label. 

 

 

 

 

 

 

 

 

 

 

 

 

Result 

The earth objects were identified with reference of image elements for given 

satellite image. 

 

 



Ex.No:05 

Date 

Introduction to QGIS 

Quantum GIS (QGIS) is a free and open source software used for viewing, editing, 

and analysis of geospatial data. 

QGIS supports most of the geospatial vector and raster file types and database 

formats. The program offers standard GIS functionality, with a variety of mapping 

features and data editing. QGIS also has support for plugins that expands its 

functionality further by providing additional tools namely: GPS data support, geo 

referencing, and additional mapping components. 

QGIS is one of the most popular software for working with spatial data. It has 

flexibility to scale with user requirements: from a simple data viewer, to data 

collection, editing and analysis, to serving data on the web – on as numerous 

machines as required and without any licensing concerns. 

 



1. Menu Bar  

In the above image 1 number is showing main menu bar. You can access 

almost everything of QGIS from main menu. You can use various features and 

functions of the QGIS menu style. The Main Menu cannot be moved unlike the 

toolbars and panels. 

2. Toolbar  

Toolbars have buttons that provide a one click access (i.e. shortcuts) to many 

of the features and functions found in the Main Menu. Toolbars are movable and 

free floating. 

3. Canvas or Map Display Panel 

It shows geographic display of GIS layer or panel layers. It covers maximum 

area off course because of its function. Create a Basic Map on canvas 

4. Browser Panel 

It provides a list of files on your computer. You can drag and drop GIS files 

into the Layers Panels to view them. This panel is movable and can be hidden/shown 

on the GUI. We can display it by right click at tool bar and choose the panels you 

want to use. 

5. Layer Panel 

This panel shows map layers that are in your current project. Layers can be 

turned on/off, clubbed, change drawing order, etc. Extract or Select features in 

Layer. 

6. Status Bar  

It display all the relevant information about the current project. It shows the 

current scale of the map display, coordinates of the current mouse cursor position, 

and the coordinate reference system (CRS) of the project. 

 

https://www.igismap.com/creating-a-basic-map-qgis/
https://www.igismap.com/select-save-export-feature-as-a-new-layer-using-qgis-3-2-1/
https://www.igismap.com/select-save-export-feature-as-a-new-layer-using-qgis-3-2-1/


Ex.No:06 

Date: 

Geo-Referencing of Images 

Aim 

To apply the co-ordinates system for given toposheet or satellite image. 

Description 

Geo-referencing is the process of assigning real-world coordinates to each 

pixel of the raster. Many times these coordinates are obtained by doing field surveys 

- collecting coordinates with a GPS device for few easily identifiable features in the 

image or map. In some cases, where you are looking to digitize scanned maps, you 

can obtain the coordinates from the markings on the map image itself. Using these 

sample coordinates or GCPs (Ground Control Points), the image is warped and made 

to fit within the chosen coordinate system. 

Procedure 

1. Georeferencing in QGIS is done via the ‘Georeferencer GDAL’ plugin. This 

is a core plugin - meaning it is already part of your QGIS installation. You 

just need to enable it. Go to Plugins ‣ Manage and Install Plugins and enable 

the Georeferencer GDAL plugin in the Installed tab. 

2. The plugin is installed in the Raster menu. Click on Raster ‣ Georeferencer ‣ 

Georeferencer to open the plugin. 

3. Now we will open our JPG image. Go to File ‣ Open Raster. Browse to the 

downloaded image of the scanned map and click Open. 

4. In the next screen, you will asked to choose the raster’s coordinate reference 

system (CRS). This is to specify the projection and datum of your control 

points. If you have collected the ground control points using a GPS device, 



you would have the WGS84 CRS. If you are geo-referencing a scanned map 

like this, you can obtain the CRS information from the map itself. Looking at 

our map image, the coordinates are in Lat/Long.  

5. The image will be loaded on the top section. 

6. Use the zoom/pan controls in the toolbar to learn more about the map. 

7. Now we need to assign coordinates to some points on this map. If you look 

closely, you will see coordinate grid with markings. Using this grid, you can 

determine the X and Y coordinates of the points where the grids intersect. 

Click on Add Point in the toolbar. 

8. In the pop-up window, enter the coordinates. Remember that X=longitude and 

Y=latitude. Click OK. 

9. You will notice the GCP table now has a row with details of your first GCP. 

10. Similarly, add other 3 GCPs covering the entire image. The more points you 

have, the more accurate your image is registered to the target coordinates. 

11. Once you have enough points, go to Settings -> Transformation settings. 

12. In the Transformation settings dialog, choose the Transformation 

type as default. Name your output raster as Name_referenced.tif. 

Choose WGS84 as the target SRS so the resulting image is in a widely 

compatible datum. Make sure the Load in QGIS when done option is checked. 

Click OK. 

13. Back in the Georeferencer window, go to File ‣ Start Georeferencing. This 

will start the process of warping the image using the GCPs and creating the 

target raster. 

14. Once the process finishes, you will see the georeferenced layer loaded in 

QGIS. 

15. The Georeferencing is now complete. But as always, it’s a good practice to 

verify your work. How do we check if our Georeferencing is accurate? In this 



case, load the country boundaries shape file from a trusted source like the 

Natural Earth dataset and compare them. You will notice they match up pretty 

nicely. There is some error and it can be further improved by taking more 

control points, changing transformation parameters and trying a different 

datum. 

 

 

 

 

 

 

 

Result 

The given topomap/satellite image were georeferenced. 

 



Ex.No: 07 

Date: 

Image Enhancement Practice 

Aim 

To improve the visibility of any portion or feature of the given satellite image. 

Description 

Enhancing the appearance of the raster data – Adjusting the brightness, contrast and 

transparency. The Image Analysis window (and the Effects toolbar) allows you to 

interactively adjust the brightness, contrast, or gamma of a raster layer or display 

the raster layer transparently. These enhancements are applied to the rendered 

screen display, not to the original raster dataset values. Brightness increases the 

overall lightness of the image. For example, making dark color lighter and light 

color white, while contrast adjusts the difference between the darkest and lightest 

colors. 

Procedure 

1. Open QGIS. 

2. Click on Add data tool and add the given satellite image. 

3. Right click on the layer and open the properties dialog box. 

4. Select symbology and RGB composite, click on display background value then 

apply. 

5. Select the stretched tool and switch on the display background value for all 

selected bands. 

6. Select the stretch type as Stretch to MiniMax and click on Apply. 

7. Then go for histogram analysis and apply stretch with the help of graph values. 

 

Result 

The visibility of the given imagery was enhanced using contrast stretching 

techniques. 



Ex.No:08  

Date: 

Supervised Classification Practice 
 

Aim 

To classify the earth feature using supervised classification (training sites) 

for given satellite image. 
 

Description 

Image classification is one of the most important tasks in image processing and 

analysis. It is used to analyze land use and land cover classes. With the help of 

remote sensing we get satellite images such as landsat satellite images. But these 

images are not enough to analyze, we need to do some processing on them. So to 

use these images for analysis we need image classification. 

There are many software tools available for image classification such as ArcGIS, 

ERDAS IMAGIN, but these are not open source software. QGIS (Quantum 

GIS) is very powerful and useful open source software for image classification. 

The basic requirement for image classification is image itself but the other important 

thing is knowledge of the region for which we are going to classify the image.  For 

this either you need to do manual survey or else you can use Google earth. Definitely 

Manual survey leads to better result. 

 

Procedure 

 Open QGIS. 

 Install SEMI AUTOMATIC CLASSIFICATION plug-in from the plugin 

option. After installation of the plugin if toolbox on the screen of the same is 

http://www.igismap.com/category/gis/quantum-qgis/
http://www.igismap.com/category/gis/quantum-qgis/


not showing by default then, then click view and click panels. And Check both 

the panels SCP: ROI creation and SCP: classification. 

 Click on Add data tool and add the given satellite image. 

 Open classification tool and select image classification. 

 Select training sample manager window. 

 Select draw polygon tool and draw on the feature (Ex: Water body, Open land, 

Vegetation, Buildings, etc.) of image. 

 Give the name and color for selected feature or objects. 

 Save the file as signature type. 

 Then go to classification tool and select maximum likelihood classification. 

 Then open signature file. 

 The classification image will be formed. 

 Right click on file in content of table. Select Layer property window and give 

the name for classified feature or objects. 

 View and Open Layout and create output save as export map in QGIS. 

 

 

 

 

 

 

 

 

 

Result 

The supervised classification process has been processed for given image. 



Ex.No:09  

Date: 

Unsupervised Classification Practice 
 

Aim 

To classify the earth feature using supervised classification (training sites) for 

given satellite image. 

 

Description 

Unsupervised classification is based on software analysis. It uses computer 

techniques for determining the pixels which are related and sort them into classes. 

 

Procedure 
 

 Open QGIS. 

 Add a raster layer in a project Layer >> Add Layer >> Add Raster Layer. 

 Go to the search box of Processing Toolbox, search KMeans and select 

the KMeans Classification. 

 Select the input image. Type the Number of classes to 20 (default classes 

are 5) . Fill training size to 10000. 

 Type the name of output image save to file. 

 And in the last tap on Run  

 Output image directly display on canvas. 

 In the layer panel, right click on the output layer and select Properties >> 

Symbology.  Change Render Type Single band Psuedocolor. Select 

the Color Ramp ( we selected spectral) 

 Choose Mode Equal Interval (default selection is continuous) 

 Change the number of classes from 5 to 20. 



 In the last click on OK. Output image is provided below. You can also 

classify according to discrete interpolation if desired. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Result 

The Unsupervised Classification process has been processed for given image. 

 

 



Ex.No:10  

Date: 

Database Management Systems 

Aim 

To study about Database Management Systems. 

Description 

A database consists of an organized collection of data for one or more uses, 

typically in digital form. A database management system (DBMS) consists of 

software that operates databases, providing storage, access, security, backup and 

other facilities. QGIS Cloud stores all your geodata in PostgreSQL/PostGIS 

databases, so it is necessary to create at least one database for your data before 

uploading any layers and publishing the map. 

To create a new database, perform the following steps: 

1. Start QGIS and activate the QGIS Cloud plugin, if it is not yet activated. 

2. Switch to the Account tab in the QGIS Cloud panel and log in using your 

username and password. 

3. Click on the Create database button at the bottom of the Account tab and 

wait until the operation completes. 

Database creation is a time-consuming operation, so be patient. When it's done, you 

will see a new database with a random name in the list of available databases. Also, 

the plugin registered this database in QGIS, so it can be used like any other PostGIS 

database, for example, for loading and editing layers from it in QGIS. 

 

 



Ex.No:11 

Date: 

Spatial Data Input and Editing - Digitizing 

Aim 

To create vector layer/ features by editing and digitizing. 

Description 

Digitizing is one of the most common tasks that a GIS Specialist has to do. In 

most instances, vector features are captured from a base data which can be a geo-

referenced map or a satellite imagery. Often a large amount of GIS time is spent in 

digitizing raster data to create vector layers that you use in your analysis. QGIS has 

powerful on-screen digitizing and editing capabilities. 

Digitizing is the process of interpreting and converting paper map or image data to 

vector digital data. In manual digitizing you trace the lines or points from the source 

media. You control a cursor, usually with a mouse or digitizing puck, and sample 

vertices to define the point, line, or polygonal features you wish to capture. The 

source media may be hardcopy, e.g., maps taped to a digitizing table, or softcopy, 

e.g., a digital image or scanned map. QGIS software allows us to digitize using either 

hardcopy or softcopy sources. 

Procedure 

1. Open QGIS. 

2. Click on Add image tool and add Open Street Map. 

3. Create New Shape files for Point, Line and Polygon features by giving 

Geometry type as Point, Line and Polygon respectively. 

4. Set Projections for the created shape files as WGS 84 and add new fields. 



5. Click Point.Shp and Click Toggle Editing. Give Unique Point number for each 

point. 

6. Similary Repeat Point Number 6 for Line.Shp and Polygon.Shp 

7. Save the output as a layout format (with Legends, Scale, North arrow, etc.) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Result 

New Vector layers/ Features were created for given map editing and digitizing 

techniques. 

 



Ex.No:12 

Date: 

Raster Analysis Problems – Database Query 

Aim 

To create a raster of a constant value within the extent and cell size of the 

analysis window. 

Description 

The basic GIS function includes Querying, Integrating and Manipulating 

Spatial data. The core functionality of GIS is that it combines computer mapping 

function that handles and displays the spatial data, with DBMS function to handle 

attribute data. 

Procedure 

 The “create constant raster tool” assigns the specified value to every cell in 

the output raster. 

 The constant value must be a numeric value scientific notation is acceptable 

(For example, 3.048e-4 for 0.003048). 

 Select constant value – The constant value with which to populate all the cells 

in the output raster. 

 Select data type. 

 Select cell size – The cell size for the output raster dataset – Analysis Cell 

Size. 

 Extent – The extent for the output raster dataset – The extent is a Python class. 

 The output raster for which each cell will have the specified constant value. 

 

Result 

The Raster analysis was performed for given data with python program. 



Ex.No:13 

Date: 

GIS Applications in DEM and its Analysis 

Aim 

To create the DEM (3D View) for given data. 

Description 

DEM is the simplest form of digital representation of topography. DEMs are used 

to determine terrain attributes such as elevation at any point, slope and aspect. Today, 

GIS applications depend mainly on DEMs respect to any reference datum. 

There is no universal usage of the terms digital elevation model (DEM), digital terrain 

model (DTM) and digital surface model (DSM) in scientific literature. In most cases, 

the term digital surface model represents the earth’s surface and includes all objects on 

it. In contrast to a DSM, the digital terrain model (DTM) represents the bare ground 

surface without any objects like plants and buildings. 

DEM is often used as generic term for DSM and DTM, only representing height 

information without any further definition about the surface.  

Procedure 

 Open QGIS 

 Click on Add data tool and add the given spatial data (Toposheet) 

 Create Point Shape file and add new point features. 

 Mark the elevation value and enter the value in point’s attribute table. 

 Select Spatial Analyst tool and apply interpolation techniques and create the 

layers spline, contour, slope, aspect, hillshade, view shed. 

 Select 3D Analyst tool and create the 3D view. 

 Save the output as a layout format (with legends, scale, north arrow, etc) 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Result 

The three dimensional view of surface were created for given toposheet. 

 



Ex.No:14  

Date: 

GIS Application in Watershed Analysis 

Aim 

To find out Watershed Basin, Streams, Flow direction, etc. 

 

Description 

A watershed is the area of land where all of the water that falls in it and drains 

off of it goes into the same place or common outlet. A watershed is also defined by 

topographic divides between two or more adjacent catchment basins, such as a ridge 

or a crest. Watershed analysis refers to the process of using DEM and raster data 

operations to delineate watersheds and to derive features such as streams, stream 

network, catchment areas, basin, etc. 

Procedure 

 Open QGIS. 

 Click on Add data tool and add the given spatial data (toposheet). 

 Choose Spatial Analyst tool and Open Hydrology tool. 

 Then create the following layers: Fill, Flow direction, Flow Accumulation, 

Basin. 

 After creating basin, open conversion tool toolbox and select raster to polygon 

tool. 

 Convert the basin raster layer to polygon. 

 Then open geoprocessing tool and clip the basin. 

 After clip the feature, go to arc toolbox and select the map algebra tool. 

 Then open raster calculator tool and create flow accumulation layers. 



 Then once again open conversion tool for raster to polygon. 

 Once again clip the basin feature. 

 Then go to data management tools, select raster and open raster processing to 

clip the feature. 

 Open and show the final clip (Flow direction and Catchment region) feature 

and save the output. 

 Save the output as a layout format (with legends, Scale, North Arrow, etc.).  

 

 

 

 

 

 

 

 

 

 

 

 

Result 

Watershed basin and Flow direction were processed. 

 



Ex.No:15  

Date: 

GIS Application in Rainfall-Runoff Modelling 

Aim 

To create a rainfall modelling for given rainfall data. 

 

Description 

Rainfall-runoff modelling is one of the important tools in engineering 

hydrology. The rainfall-runoff process describes the water changes from rainfall to 

runoff during a storm event. It is necessary for hydrologists to investigate the 

rainfall-runoff processes because it identifies the hydrological characteristics of a 

watershed. The rainfall-runoff relationship is strongly dependent on soil, the types 

and diversity of vegetation, and topographic characteristics of the watershed. Since 

these characteristics are highly dynamic in the spatial domain, GIS can play a very 

important role in rainfall – runoff modelling. Recent developments in GIS 

techniques have enhanced the capabilities to even handle large dataset describing 

the heterogeneities in land surface characteristics. 

Procedure 

 Open QGIS. 

 Click on Add data tool and add the given spatial data (toposheet). 

 After adding data, choose spatial analyst tool. 

 Select interpolation tool and Open IDW tool. 

 Create a spline using interpolation tool. 

 Then open surface tool and create contour, drainage, etc. 

 Use hydrology tool for stream, stream order, flow direction, basin, etc. 



 Create and show the rainfall map. 

 Save the output as a layout format (with legends, scale, north arrow, etc). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Result 

The rainfall map was created for given data. 

 

 



Ex.No:16  

Date: 

GIS Application in Soil Erosion Modelling 

Aim 

To create Soil Erosion modelling for given data. 

 

Description 

Soil erosion assessment is a capital-intensive and time-consuming exercise. A 

number of parametric models have been developed to predict soil erosion at drainage 

basins, yet universal soil loss equation (USLE) is most widely used empirical 

equation for estimating annual loss from agricultural basins. While conventional 

methods, yield point-based information, Remote Sensing (RS) technique makes it 

possible to measure hydrologic parameters on spatial scales while GIS integrates the 

spatial analytical functionality for spatially distributed data. Some of the inputs of 

the model such as cover factor and to a lesser extent supporting conservation practice 

factor and soil erodibility factor can also be successfully derived from remotely 

sensed data. Maps covering each parameter (R, K, LS, C and P) were integrated to 

generate a composite map of erosion intensity based on advanced GIS functionality. 

This intensity map was classified into different priority classes. Each area was 

analyzed individually in terms of soil type, average slope, drainage length, drainage 

density, drainage order, height difference, land use/land cover and average NDVI 

with soil erosion to find out the dominant factor leads to higher erosion. 

 

 



Procedure 

 Open QGIS. 

 Click on Add data tool and add the given spatial data (toposheet). 

 After adding data, choose spatial analyst tool. 

 Select Zone tool and open zone statistics, zone fill, zone, etc. 

 Show the soil erosion zone using above tools. 

 Save the output as a layout format (with legends, scale, north arrow, etc.). 

 

 

 

 

 

 

 

 

 

 

 

Result 

 The soil Erosion Map was created for given data. 
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